迁移#

Here are some migration guides to help you transition from other libraries to joserfc:

对比#

joserfc is the most feature-complete Python library for the JOSE specifications, providing full coverage of all relevant RFCs.

The following highlights the key differences between joserfc and other Python libraries:

Features

joserfc

authlib.jose

pyjwt

python-jose

jwcrypto

Type Hints

是

否

是

否

否

Compact JWS

是

是

是

是

是

JSON JWS

是

是

否

否

是

Compact JWE

是

是

否

是

是

JSON JWE

是

是

否

否

是

Key generation

是

是

否

Yes

是

Key importing

是

是

否

Yes

是

JWT on JWS

是

是

是

是

是

JWT on JWE

是

是

否

否

是

RFC7638

是

是

否

否

是

RFC7797

是

否

是

否

是

RFC8037

是

是

是

否

是

RFC8812

是

是

是

否

是

RFC9278

是

否

否

否

否

RFC9864

是

否

否

否

Not released